Following the restoration of all PowerBI report functionalities and a stable period of monitoring, the incident has been marked as resolved.
Posted Jul 14, 2025 - 08:19 UTC
Monitoring
A fix has been implemented and full functionality is restored in all impacted regions. Engineers will continue to monitor the platform for a period before the incident is marked as resolved.
Posted Jul 14, 2025 - 07:15 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2025 - 00:48 UTC
Investigating
We are investigating an incident which is causing OrbusInfinity PowerBI Reports to fail to load.
All other areas of the OrbusInfinity application are working as normal.
Engineers are actively engaged and investigating the issue.
Posted Jul 14, 2025 - 00:46 UTC
This incident affected: Australia East (OrbusInfinity), SolutionsHub, and IRAP (Australia) (OrbusInfinity).