Microsoft has published the updated OrbusInfinity connector for Power Automate. The issue is now resolved, we are continuing to monitor any potential problems.
Posted Aug 06, 2026 - 10:53 UTC
Update
We are still awaiting Microsoft to publish the updated OrbusInfinity connector for Power Automate. There is no change to report at this stage, and we do not yet have an ETA, but we are continuing to chase this with Microsoft as a priority. We will update here as soon as we have more to share. Thank you for your continued patience.
Posted Jul 31, 2026 - 15:14 UTC
Update
We are continuing to work with Microsoft to restore the OrbusInfinity connector for Power Automate. The change required is still pending on Microsoft's side, and we are awaiting the updated connector to be published. We do not have an ETA at this time, but we will update here as soon as we have more to share. Thank you for your continued patience.
Posted Jul 28, 2026 - 13:04 UTC
Identified
We are aware of an issue affecting the OrbusInfinity connector for Power Automate. Affected connections are currently unable to authenticate, and you may see an authorisation error (e.g. an "OAuth2 authorization flow failed" or "invalid client" message) when a flow attempts to connect to OrbusInfinity.
This is caused by an authentication credential on the Orbus side that requires renewal. The renewal was submitted ahead of the expiry, and the necessary change is now with Microsoft to apply. Service will be restored once Microsoft have completed the work on their side. We do not currently have an ETA for completion and this may take some time.
You do not need to change anything on your end. We are working with Microsoft and will post further updates here as we make progress, confirming once connections are fully restored. Thank you for your patience.