OrbusInfinity PowerBI Reports
Incident Report for Orbus Software
Postmortem

Incident Summary

Following the upgrade of OrbusInfinity to v1.121 on 17/01/25 across the impacted regions, it was no longer possible to utilize the PowerBI widget with Dashboards within the application itself.  This was resolved overnight (17th / 18th January) by Orbus engineers following an update of settings and a full application restart.

Impact

Following the deployment of 1.121 during the standard scheduled maintenance window on 17/01/25, the PowerBI widget stopped working with OrbusInfinity Dashboards.  It was not possible to add new or amend existing PowerBI widgets within Dashboards for the duration of the incident.  Full Dashboard functionality was restored on the morning of 18/01/25 following an application change and full restart of OrbusInfinity (not just Dashboard services).

Root Cause Analysis

An issue originating in the external cloud services deployment platform utilized in the management of OrbusInfinity, led to a service description / setting not being retrieved by the service controlling the PowerBI Dashboard widget at the time of the upgrade.  This resulted in the impacted service not being fully and correctly configured, meaning it was unable to communicate with other linked services.

To restore functionality to the PowerBI Dashboard widget, the setting was updated by engineers and a full application restart initiated outside of core business hours for each impacted region.

A subsequent manual workaround has been applied to the deployment platform which will ensure the required settings are retrievable for future deployments.  This ensures we maintain the ability to deploy OrbusInfinity at any time.

Regardless of the manual workaround being applied, we remain actively engaged with the cloud services provider to ensure all mitigating actions are closed out with a view to preventing a recurrence of the issue in the deployment platform in future.

Posted Jan 23, 2025 - 09:28 UTC

Resolved
Following a restart of the OrbusInfinity application outside of business hours, full functionality has been restored.
Posted Jan 18, 2025 - 10:35 UTC
Identified
An issue has been identified with OrbusInfinity PowerBI Reports in some regions. A fix has been identified by engineers but this will require a brief period of application downtime. The fix will therefore be applied outside of business hours in each impacted region.

The PowerBI reporting widget and some instances of SharePoint WebPart reports may be impacted and not working.

All other areas of the OrbusInfinity application are working as normal.
Posted Jan 17, 2025 - 16:45 UTC
This incident affected: Canada Central (OrbusInfinity), United Arab Emirates North (OrbusInfinity), United Kingdom South (OrbusInfinity), Europe West (OrbusInfinity), United States East (OrbusInfinity), and United States West (OrbusInfinity).